#115 ✓resolved
Conrad

LoadError in Ubuntu Lucid

Reported by Conrad | August 26th, 2010 @ 06:20 PM | in 0.8.6

After running sudo gem install adhearsion, executing ahn -h gives me:

/usr/bin/ahn:19:in `load': no such file to load -- /usr/lib/ruby/gems/1.8/gems/adhearsion-0.8.5/bin/ahn (LoadError) from /usr/bin/ahn:19

I'll try to give as many other relevant details as possible. I have created this error on two separate machines running the same versions of Ubuntu (Ubuntu Lucid). The first machine used Adhearsion's installation process to a tea, except instead of apt-get I used aptitude. The second Ubuntu install had rubygems compiled from source, but everything else installed from aptitude.

ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
gem -v
1.3.7

Additionally, if I attempt to install adhearsion again:

sudo gem install adhearsion
Successfully installed adhearsion-0.8.5
1 gem installed

And lastly:

irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'adhearsion'
LoadError: no such file to load -- adhearsion

    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
    from (irb):2
    from :0



irb(main):003:0>

Comments and changes to this ticket

  • Conrad

    Conrad August 26th, 2010 @ 06:32 PM

    To give a little update - I installed adhearsion from the git repo, and it seems to be working just fine!

  • Ben Klang

    Ben Klang August 29th, 2010 @ 05:21 PM

    • Assigned user set to “Ben Klang”

    I have just tried to reproduce this on a Kubuntu Lucid install that I had handy. I did run into one problem because my umask was set too restrictively. Because the 'adhearsion.rb' file was not readable I would get LoadError exceptions. Try this:

    sudo chmod o+rX /var/lib/gems

    Once doing that I could require 'rubygems' and 'adhearsion' in irb without exceptions.

  • Conrad

    Conrad August 29th, 2010 @ 06:10 PM

    Okay, but why did installing any other gem (gem install rails) work without any errors upon requiring them?

  • Ben Klang

    Ben Klang August 30th, 2010 @ 06:58 PM

    • Milestone set to 0.8.6
    • State changed from “new” to “open”
    • Milestone order changed from “3032” to “0”

    I have traced the issue to a local umask setting that was used when packaging the gem that was ultimately published as Adhearsion-0.8.5. I tried republishing a version of 0.8.5 that had the file modes corrected but was unable to do so. This will be fixed in the next release of Adhearsion (0.8.6). In the meantime, the fix is to chmod the files manually as noted above.

  • Ben Klang

    Ben Klang September 3rd, 2010 @ 02:07 PM

    • State changed from “open” to “resolved”

    Adhearsion 0.8.6 has been released, which fixes this issue.

    http://digitalmantra.org/post/1059457171/bugfix-release-adhearsion-...

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Pages